注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

K8拉登哥哥's Blog

K8搞基大队[K8team] 信息安全 网络安全 0day漏洞 渗透测试 黑客

 
 
 

日志

 
 

[环境]IPHONE 上安装MSF (Metasploit 4.0.0 ruby 1.8.6) 运行成功  

2014-02-23 17:49:45|  分类: 手机/Mobile |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

前段时间越狱了 然后大概在过年那时候有几天空闲时间 给手机装个msf
过程中并没有那么顺利,直接cydia上下回来的 运行不了 坑爹。。。
[环境]IPHONE 上安装MSF (Metasploit 4.0.0 ruby 1.8.6) 运行成功 - K8拉登哥哥 - K8拉登哥哥s Blog
 
进入安装metasploit的目录
cd /private/var
下载安装ruby环境,不要使用最新的,cydia提示也别更新,否则metasploit将无法运行,使用下面的命令来下载并且安装。
1 wget http://updates.metasploit.com/data/releases/framework-4.0.0.tar.bz2

上面下不了了 只能去GIT的msf官方上下载

4.0.0   f1768564be92abcea3ea34fde14acb1af4d52f1d

4.8.2   9722a29d792b4b109635b0e6143809153b047c28

因为直接在iphone上下 会比较慢
所以先在电脑上下载完成后 用K8迷你ASP服务器 架设一个web
然后在iphone上能通过wget下载到手机上
wget http://192.168.1.113/framework-4.8.2.tar.bz2
wget http://192.168.1.113/framework-4.0.0.tar.bz2   

  解压缩 (可以用ifle直接到var目录解压)
 tar jxpf framework-4.0.0.tar.bz2   

tar jxpf framework-4.8.2.tar.bz2

 
 apt-get remove ruby rubygems
 
 wget http://apt.saurik.com/dists/tangelo-0.9/main/binary-iphoneos-arm/debs/ruby_1.8.6-p111-5_iphoneos-arm.deb
 
 dpkg -i ruby_1.8.6-p111-5_iphoneos-arm.deb
 
 wget http://apt.saurik.com/dists/tangelo-0.9/main/binary-iphoneos-arm/debs/rubygems_1.2.0-3_iphoneos-arm.deb
 
 dpkg -i rubygems_1.2.0-3_iphoneos-arm.deb
好了 安装好了
现在进入Metasploit目录
 cd msf3
 
 ./msfconsole  打开 metasploit
我这里装的是metasploit4.0  你也可以安装别的版本 但是我试了下  最新的4.3貌似不兼容 4.2有个文件提示错误 删除就可以了
下面这个是metasplot官方下载地址
https://github.com/rapid7/metasploit-framework/wiki/Downloads-by-Version


4.0.0 安装后终于成功

4.8.2 实际运行后 出现  可能是ruby版本不兼容
[*] Metasploit requires the Bundler gem to be installed
    $ gem install bundler
  评论这张
 
阅读(1961)| 评论(1)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2016